SharePoint 2013 Content Search Web Part: One or more of the following resource files failed to load

When adding the Content Search Web Part to a site for the first time, the web part took a while to load, then displayed the error:

One or more of the following resource files failed to load: /_catalogs/masterpage/display templates/language files/en-GB/customstrings.js?ctag=322$$15.0.4569.1000

CSWP0

To look for the missing file I went to Site Settings, then Master page and page layouts, which is under the heading Web Designer Galleries.  On that page I navigated through Display Templates -> Language Files.  I could see that for some reason the en-GB folder was missing.

CSWP1

The fact that the folder was missing was odd because I’d used the Content Search Web Part before within the Site Collection.  Anyway, to resolve the error I created the en-gb folder and copied customstrings.js from the en-us folder and pasted it into en-gb.

CSWP2

Advertisements

4 thoughts on “SharePoint 2013 Content Search Web Part: One or more of the following resource files failed to load

  1. Aivovaurio

    I had same problem when changed language in Finnish. WebPart worked correctly in English, but now in Finnish. Same trick worked for this as well. Thanks!

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s